Download now not working on archive pages

Posted by: Charlie

15th January 2021, 5:04 pm



15 Jan 2021
5:04 pm

Hi, this is really weird, I uploaded fresh products today - all worked fine.

Literally an hour later, for no explainable reason, the download button on the archive page stopped working, and instead opens up the product for viewing.

On the product page, the download buttons seem to work fine, but on the archive page, it;s not downloading, it;s just opening the product.

No idea what's changed! I haven't altered any settings.

Also, I tried to update the plugin on a staging site and got an error. So I don't dare try to update the plugin on my live site. I'm on version 3.2.22 currently.

I'm going to start getting support requests as it's just happened, so please please please respond asap!!

  • Charlie


    15 Jan 2021
    5:07 pm

    also tried clearing cache etc!

  • Charlie


    15 Jan 2021
    5:10 pm

    ok... i cleared my minify cache and it's working again... really odd!

    all seems ok now, not sure why that happened?

    probably jumped on the forum a tad too soon!

  • Richard Webster


    15 Jan 2021
    6:28 pm

    It's ok Charlie, let me know if you have any more problems 🙂

This topic is closed to new replies.